*HOT issues/ Bugs/ etc. here please

Home Forums Fupoco Discussion HOT issues/ Bugs/ etc. here please

Viewing 15 posts - 76 through 90 (of 118 total)
  • Profile photo of FirewolfeFirewolfe
    Member
    #2095

    No, I’m kind of a luddite, I don’t like wireless devices much. I use regular corded mice and keyboards.

    Profile photo of evilmathmagicianevilmathmagician
    Participant
    #2096

    I’ve decided to stop trying to make my laptop suitable for running HoT. This is mainly because I want to have the glitch art, I’m not supposed to be playing games on this laptop in the first place, and I can play it on my desktop computer.
    Thank you for trying to help me, though, Kaive and Avanti and Whry and Firewolfe.

    Profile photo of AvantiAvanti
    Member
    #2099

    @evilmathmagician np. and @Firewolfe these links may prove useful: http://gmc.yoyogames.com/index.php?showtopic=551388 and http://bugs.yoyogames.com/view.php?id=6275 it looks like it might just be as simple as having a file named differently then in a previous version of the game(which might end up needing a clean install of the updated version) or an issue with uninitialized variables which I would have no idea how to fix, I’ve only worked on text based games myself(graphics, they are difficult :S)

    Profile photo of FirewolfeFirewolfe
    Member
    #2100

    Hey guys, got back sooner than expected. Avanti, I’ll have a look at those links tonight after work, also I’ll check the files I’ve got to make sure if anything looks out of place. I save each build just in case something like this were to happen, so I get to play detective later :3

    Profile photo of FirewolfeFirewolfe
    Member
    #2101

    Ok, I messed around with the game and the item crash hasn’t happened again, so I have no idea what I did that last time…
    Also checked those links and some of that went over my head mostly since I haven’t programmed anything in a long time o_o

    Profile photo of AvantiAvanti
    Member
    #2102

    Firewolfe it looks like it is likely just a scripting issue, and if you haven’t had this issue again then it is probably just some leftovers from the last version(which is likely if you updated and didn’t restart, the old version would still be active-ish in the system memory alongside the new one, something rather important for data recovery btw) and the error was unable to be reproduced again , then this is likely the case and would not require a clean install, which might be required if some other program is accessing the files(not sure how often it would happen on windows, but it happens every now and then on Wine, mostly due to having to use different wineprefixes and using more then one prefix at once) in which case said error wouldn’t happen unless the resource greedy program is active(also happens to be a cause for many graphical issues, I’ve seen plenty of games not work in windows for some reason, then work fine in safe mode) so yeah, probably not a big issue, if it happens again then you would probably have to manually go in and fix it, which would be rather complicated without knowledge of what is causing the problem…

    Profile photo of FirewolfeFirewolfe
    Member
    #2104

    Yeah, I failed at Javascript in my last coding class (which thankfully was HTML, so no huge points loss) ^_^Β° As you said, I would have no idea what I’m looking for in the script files that would cause the problem. I am looking forward to the day I can switch to a part-time job and revisit my interests that I’ve had to put on hold. Adulthood sux, lol!

    Still haven’t gotten the item-triggered mouse script error, so I may have tried playing a new installation without the mandatory restart, like you suggested.

    Profile photo of KaiveKaive
    Keymaster
    #2109

    Does that mean I’m off the hook? ^^;

    (Will mark this issue as ‘maybe resolved?’ in my bug notes.)

    Profile photo of AvantiAvanti
    Member
    #2110

    Well if its not popping up again its probably just “operator error” πŸ˜› so yeah, not likely a major issue(or even an issue at all, these things just happen every now and then) here.

    Profile photo of FirewolfeFirewolfe
    Member
    #2113

    That seems to be the case. I’ve messed around with the items several times now and the error doesn’t come up, so it must have been an installation glitch since I didn’t restart. That being said, I -suppose- Kaive is off the hook~ XD

    Profile photo of AvantiAvanti
    Member
    #2117

    Looks like it. Any other delicious errors? XD

    Profile photo of FirewolfeFirewolfe
    Member
    #2119

    Not yet, but I’ll holler if I find any πŸ˜€

    Profile photo of KaiveKaive
    Keymaster
    #2121

    Granted, the one about the game stalling the longer you play online is pretty hefty. I was able to replicate it. Quite embarrassing.

    Profile photo of AvantiAvanti
    Member
    #2126

    Well like I said(I believe in another thread) about the online issues, its something that’s an issue with most browsers, for Firefox(and Chrome) its due to them using up a lot of system memory(my atm is using 420MB probably going to have to relaunch it soon) and once it reachs a certain amount(~720MB-1200MB depending on your system, OS, firefox setup, etc) the browser experiences severe lag and even crashes, the simplest solution is to play online games in a light weight browser(like Midori on Ubuntu) open in a seperate browser, or launch a new instance of said browser under a new process, and this issue won’t be resolved unless there are major overhauls to the browsers themselves(and Java, the code is quickly reaching its limits) then all you could do is try to make it use less browser resources(which would likely involve removing several features) or have the end user, at the very least, close some of those extra tabs/windows they have open(as an exception to this, however, in custom builds of firefox or exceptionally good computers(think $23000ish custom built ones) there is no issue with online at all, even when having as many as 1300 tabs open(only seen this once tho)) but yeah, its a major issue with the browsers, I’ll go link hunting and see if I kann find something new about it, other then that, not much kann be done other then not opening a lot of tans/windows, and regularly restarting your browser :I.

    Profile photo of FirewolfeFirewolfe
    Member
    #2127

    When I did the browser experiment, all sessions were started in a fresh new window, I have over 3GB physical memory, of which 2.2GB was available, 2GB virtual memory, and 6.8GB page file space, so I wasn’t running on meager resources. The processor is supposedly equal to 2.7Ghz and I run a Radeon x1600 card as well, so I’m at a loss as to why this was happening on all the browsers I tested… Windows XP SURELY isn’t that pathetic! XD

Viewing 15 posts - 76 through 90 (of 118 total)

You must be logged in to reply to this topic.